1 | molecuilder (1.6.1-1) UNRELEASED; urgency=low
|
---|
2 |
|
---|
3 | * Added ChemicalSpaceEvaluator Action to assess stability of all possible
|
---|
4 | molecules that match a given Graph6 string using fragmentation method
|
---|
5 | principles.
|
---|
6 | * Python Interface supports (and recommends using) named parameters.
|
---|
7 | Moreover, save-session will write scripts with named parameters.
|
---|
8 | * GUI displays forces and velocities as additional vectors per atom.
|
---|
9 | * AutomationFragmentationAction checks whether workers are still busy and
|
---|
10 | aborts when all workers have crashed.
|
---|
11 | * JobMarket: is now robust when worker or server is killed by signal.
|
---|
12 | * JobMarket: Added GetNumbersOfWorkerOperation.
|
---|
13 | * ForceAnnealing/StructreOptimization Action can now take the bond graph
|
---|
14 | information into account and significantly speed up optimization up to a
|
---|
15 | factor of 3.
|
---|
16 | * added molecular dynamics and structure optimization integration tests.
|
---|
17 | * FIX: recreated and fixed guicheck tests.
|
---|
18 | * StretchBondAction now takes the bond graph into account.
|
---|
19 | * Added examples test case with many ways of translation atoms, see blog
|
---|
20 | post.
|
---|
21 | * enhanced precision of tremolo format making it the recommended file format
|
---|
22 | to use!
|
---|
23 | * Tremolo file format now supports multiple time steps.
|
---|
24 | * DOCU: Updated userguide on empirical potential using HomologyGraph.
|
---|
25 | * Added SelectAtomByName action.
|
---|
26 | * DOCU: several fixes to userguide.
|
---|
27 | * FIX: GUI again reacts to WorldTime changes, i.e. time slider.
|
---|
28 | * changed email address to sent bug reports to.
|
---|
29 | * Added AtomRandomPerturbation to randomly displace atoms.
|
---|
30 | * DOCU: explained wait() necessity in python scripts.
|
---|
31 | * StepWorldTime now uses a single argument.
|
---|
32 | * FIX: Status messages are now always pushed to log, even when logging is
|
---|
33 | captured in GUI.
|
---|
34 | * RotateToPAS has working undo/redo.
|
---|
35 | * Added RotateAroundBond action for rotating molecule around specific bond.
|
---|
36 | * Added very powerful GeometryObjects to use as any vector object or for
|
---|
37 | simply measuring distances and angles in the GUI.
|
---|
38 | * CodePatterns, fix: Chronos is thread-safe, and protecting Verbosity.
|
---|
39 | * fixes: regression tests ports between 11024 and 19999.
|
---|
40 | * builds on Ubuntu 16.04
|
---|
41 | * MemDebug is now disabled by default.
|
---|
42 |
|
---|
43 | -- Frederik Heber <heber@molecuilder.com> Fri, 02 Mar 2017 23:45:24 +0100
|
---|
44 |
|
---|
45 | molecuilder (1.6.0-1) UNRELEASED; urgency=low
|
---|
46 |
|
---|
47 | * Dependent packages CodePatterns, JobMarket, levmar, MPQC(_open), and vmg
|
---|
48 | are now contained in the distribution under ThirdParty packages.
|
---|
49 | * Debian package can be easily created.
|
---|
50 |
|
---|
51 | -- Frederik Heber <heber@molecuilder.com> Fri, 02 Mar 2017 23:45:24 +0100
|
---|
52 |
|
---|
53 | molecuilder (1.5.4-1) UNRELEASED; urgency=low
|
---|
54 |
|
---|
55 | * initial code for allowing charge grids for long-range calculations to work
|
---|
56 | independently for fragments.
|
---|
57 | * fixes to SaturateBond, now properly working by using full
|
---|
58 | SphericalPointDistribution and combinatorial matching to present bonds.
|
---|
59 | * fragment results can now be parsed and save in extra action, not bound to
|
---|
60 | fragmentationautomation oder analysefragmentresults.
|
---|
61 | * fixed fragmentation on subset of atoms.
|
---|
62 | * QtFragmentList now supports proper sorting.
|
---|
63 | * logview in GUI may be disabled by configure-switch.
|
---|
64 | * fitted partial charges are now stored using save/parse-particle-parameters.
|
---|
65 | * introduced implicit charges.
|
---|
66 | * fragmentation-automation fails when server is not/no longer accessible.
|
---|
67 | * fit-partial-charges fits to currently selected atoms and creates unique
|
---|
68 | particles.
|
---|
69 | * removed parse-tremolo-potentials as is superceded by
|
---|
70 | parse-particle-parameters.
|
---|
71 |
|
---|
72 | -- Frederik Heber <heber@molecuilder.com> Fri, 30 Sep 2016 17:45:24 +0200
|
---|
73 |
|
---|
74 | molecuilder (1.5.3-1) UNRELEASED; urgency=low
|
---|
75 |
|
---|
76 | * QtGui now crashes only in 1-2% of all regression tests (new record).
|
---|
77 | * we copy all information regarding visual entities and regaring the
|
---|
78 | displayed lists via QtObserved... instances or via central ..Observer
|
---|
79 | entities.
|
---|
80 |
|
---|
81 | -- Frederik Heber <heber@molecuilder.com> Sun, 25 Apr 2016 09:11:24 +0200
|
---|
82 |
|
---|
83 | molecuilder (1.5.2-1) UNRELEASED; urgency=low
|
---|
84 |
|
---|
85 | * Introduced QtObservedInstanceBoard as clean interface between World and QtGui.
|
---|
86 | * Bugfix to FillRegularGrid.
|
---|
87 | * FitParticleCharge -> FitPartialCharge.
|
---|
88 |
|
---|
89 | -- Frederik Heber <heber@molecuilder.com> Sun, 03 Mar 2016 13:48:57 +0100
|
---|
90 |
|
---|
91 | molecuilder (1.5.1-1) UNRELEASED; urgency=low
|
---|
92 |
|
---|
93 | * Incorporated libcodepatterns rename and other fixes for debian packaging.
|
---|
94 | * More efficient bounding box in molecule, effectively O(log N).
|
---|
95 | * Enhanced hbond distances with more values and consolidated from
|
---|
96 | optimization calculations.
|
---|
97 | * VMG forces now are also working for the long-range part.
|
---|
98 | * Interdistance now combines couples of fragments till a given order.
|
---|
99 | * Smearing of electronic charge distributions greatly improves electronic
|
---|
100 | long-range component.
|
---|
101 |
|
---|
102 | -- Frederik Heber <heber@molecuilder.com> Sun, 06 Feb 2016 23:16:00 +0100
|
---|
103 |
|
---|
104 | molecuilder (1.5.0-1) UNRELEASED; urgency=low
|
---|
105 |
|
---|
106 | * Initial Release.
|
---|
107 | * This is my first Debian package.
|
---|
108 |
|
---|
109 | -- Frederik Heber <heber@molecuilder.com> Sun, 09 Aug 2015 21:37:00 +0100
|
---|